Jump to main content Jump to doc navigation

MODX отлично работает на большинстве виртуальных/облачных хостингов, а также на VPS и выделенных блоках. MODX написан на PHP, обычно использует базу данных MySQL и нуждается в веб-сервере, таком как Apache или NGINX, для обслуживания веб-запросов.

Компонент Минимально Рекомендация
PHP 7.1-7.4 7.3
Database Последняя MySQL 5.5+ MariaDB 10.1.x или MySQL 5.7

PHP

Для MODX 3 требуется, как минимум PHP 7.1, но рекомендуется выше.

Следующие расширения требуются MODX, или обычно требуются дополнениями: zlib, json, gd, pdo (конкретно pdo_mysql), imagick, simplexml, curl, и mbstring. Это общие расширения, которые обычно включены по умолчанию.

Рекомендуется memory_limit как минимум 64M или выше.

База данных

MODX поддерживает различные драйверы баз данных, в том числе mysql, sqlsrv и стороннюю реализацию postgres. Важно отметить, что статисты также должны реализовывать различные драйверы для своих пользовательских таблиц базы данных, что часто делается только для mysql, что делает вас лучшим выбором.

Минимальная поддерживаемая версия MySQL - 4.1.20, но рекомендуется 5.7 или выше. Также можно использовать кластеры, такие как Galera.

Поддерживаются механизмы хранения MyISAM и InnoDB, а также наборы символов utf8 и utf8mb.

Требуются следующие разрешения:

  • SELECT, INSERT, UPDATE, DELETE необходимы для нормальной работы,
  • CREATE, ALTER, INDEX, DROP для установки. обновления ядра и, возможно, для различных дополнений,
  • CREATE TEMPORARY TABLES некоторыми сторонними дополнениями.

Веб-серверы

MODX будет работать на большинстве веб-серверов, доступных сегодня. Рекомендуется Apache 2.4+ или nginx 1.8+.

Чтобы использовать friendly urls, вам может потребоваться дополнительная настройка в зависимости от веб-сервера. Инструкции доступны для nginx и lighttpd.

Поддержка браузера для Менеджера

Для использования внутреннего интерфейса поддерживаются следующие браузеры рабочего стола:

  • Internet Explorer 11
  • Edge (последние 2 версии)
  • Chrome (последние 2 версии)
  • Firefox (последние 2 версии)
  • Safari (последние 2 версии)

Поддерживаемые мобильные/планшетные браузеры:

  • Chrome for Android (последний)
  • Safari on iOS (последний)

Менеджер может нормально работать в старых или других браузерах, но они официально не поддерживаются.

Обратите внимание, что эти требования только для менеджера. Какие браузеры поддерживает ваш сайт, решать только вам!